Instalação do WampServer 3.1.0 no Windows 10: 08/07/2018

A instalação do WampServer 3.1.0 foi feita no  Windows 10 Home Single Language, 64 bits, processador com base de x64.
W: Windows
a: apache é o servidor propriamente dito.
m: mysql é o banco de dados, onde cria-se banco de dados e tabelas.
p: php é a linguagem utilizada para trabalhar com páginas da internet no servidor.

WampServer é uma plataforma de desenvolvimento web baseada em Windows para aplicações web dinâmicas usando o servidor Apache2, linguagem de script PHP e banco de dados MySQL.
A versão atual (07/07/2018) é o Wampserver 3.1.0 64 bits (x64) ou Wampserver 3.1.0 32 bit (x86):
Apache 2.4.27 - PHP 5.6.31, 7.0.23, 7.1.9 - MySQL 5.7.19 - MariaDB 10.2.8 - PhpMyAdmin 4.7.4 - Administrador 4.3.1 - PhpSysInfo 3.2.7

Para travalhar com banco de dados não é necessário digitar o código mysql, o banco de dados e as tabelas são criados com o phpMydmin que é um administrador de banco de dados que já vem com o Wampserver.

Instalação
Passo1:
antes mesmo da instalação do WampServer 3.0.1 é necessário a instalação do Visual C ++ Redistributable para o Visual Studio 2013. O Wamp não poderá ser iniciado sem o arquivo MSVCR120.dll no seu computador.  Esse arquivo  é uma parte do Microsoft Visual C ++. Caso tenha feita a instalação sem esse plugin desistale o WanpServer e instale primeiro o Visual C ++ Redistributable para o Visual Studio 2013.

As duas mensagens de erro abaixo formam causadas pela instalação do Visual C ++ Redistributable para o Visual Studio 2017 e Visual C ++ Redistributable para o Visual Studio 2015.





A versão que instalou corretemente no Windows 10 foi a Visual C ++ Redistributable para o Visual Studio 2013.

Instalação do Visual C ++ Redistributable para o Visual Studio 2013:

- Acesse o site: https://www.microsoft.com/pt-br
Pesquise por
Visual C ++ Redistributable na barra de pesquisa do site.
Procure por
Visual C ++ 2013 ou algo parecido.
Clique no Link:
https://www.microsoft.com/en-us/download/details.aspx?id=40784
Clique no botão: Download
Marque o arquivo: vcredist_x64.exe (no meu caso)
Clique no botão NEXT (canto inferior direito)
- Vá até a pasta de download e clique com o botão direito do mouse e escolha a opção executar como administrador. Dê sequencia na instalação.

Passo2:  Download do Wampserver 3.1.0 (2015-11-12)
- Acesse o site: http://www.wampserver.com
- Escolha o arquivo conforme o seu sistema operacional, no meu caso é o Wampserver 3.1.0 x64 64 bits:
 
Wampserver 3.1.0 x64 64 bits ou Wampserver 3.1.0 32 bit x86:
Apache 2.4.27 - PHP 5.6.31, 7.0.23, 7.1.9 - MySQL 5.7.19 - MariaDB 10.2.8 - PhpMyAdmin 4.7.4 - Administrador 4.3.1 - PhpSysInfo 3.2.7
Ao clicar na figura aparecerá a seguinte orientação, repare que é referente ao Wampserver 2, mas pode se fazer uma analogia com o Wampserver 3.
Clique no Link: Alternar para o download direto
Escolha: Wampserver 3


Passo 2: Vá para a pasta onde foi baixado o arquivo wampserver3.1.3_x64.exe (meu caso) e dê um  clique com o botão direito do mouse e escolha a opção executar como administrador.


Clique em Ok!

Passo3:


Clique em Next!

Passo4:

Clique em Next!

Instruções da figura acima sobre a instalação:
--- Installation of Wampserver ---
BEFORE proceeding with the installation of Wampserver, you must ensure that certain elements are installed on your system, otherwise Wampserver will absolutely not run, and in addition, the installation will be faulty and you need to remove Wampserver BEFORE installing the elements that were missing.
Make sure you are "up to date" in the redistributable packages VC9, VC10, VC11, VC13 ,  VC14 and VC15
See --- Visual C++ Packages below.
--- Do not install Wampserver OVER an existing version, follow the advice:
- Install a new version of Wampserver: http://forum.wampserver.com/read.php?2,123606
If you install Wampserver over an existing version, not only it will not work, but you risk losing your existing databases.
--- Install Wampserver in a folder at the root of a disk, for example C:\wamp or D:\wamp. Take an installation path that does not include spaces or diacritics; Therefore, no installation in c: \ Program Files\ or C: \ Program Files (x86\
We must BEFORE installing, disable or close some applications:
- Close Skype or force not to use port 80
Item No. 04 of the Wampserver TROUBLESHOOTING TIPS:http://forum.wampserver.com/read.php?2,134915
- Disable IIS
Item No. 08 of the Wampserver TROUBLESHOOTING TIPS:http://forum.wampserver.com/read.php?2,134915
If these prerequisites are not in place, Press the Cancel button to cancel the installation, then apply the prerequisites and restart the installation.
This program requires Administrator privileges to function properly. It will be launched with the "Run as administrator" option. If you do not want a program to have this option, cancel the installation.
--- Visual C++ Packages ---
The MSVC runtime libraries VC9, VC10, VC11 are required for Wampserver 2.4, 2.5 and 3.0, even if you use only Apache and PHP versions with VC11. Runtimes VC13, VC14 is required for PHP 7 and Apache 2.4.17 or more
-- VC9 Packages (Visual C++ 2008 SP1)
http://www.microsoft.com/en-us/download/details.aspx?id=5582
http://www.microsoft.com/en-us/download/details.aspx?id=2092
-- VC10 Packages (Visual C++ 2010 SP1)
http://www.microsoft.com/en-us/download/details.aspx?id=8328
http://www.microsoft.com/en-us/download/details.aspx?id=13523
-- VC11 Packages (Visual C++ 2012 Update 4)
The two files VSU4\vcredist_x86.exe and VSU4\vcredist_x64.exe to be download are on the same page: http://www.microsoft.com/en-us/download/details.aspx?id=30679
-- VC13 Packages Update 5(Visual C++ 2013)
The two files VSU4\vcredist_x86.exe and VSU4\vcredist_x64.exe to be download are on the same page: https://support.microsoft.com/en-us/help/4032938/
-- VC14 Packages (Visual C++ 2015 Update 3) Supersedes by VC15
- VC15 Redistribuable (Visual C++ 2017)
https://aka.ms/vs/15/release/VC_redist.x86.exe
https://aka.ms/vs/15/release/VC_redist.x64.exe
VC2017 (VC15) is backward compatible to VC2015 (VC14). That means, a VC14 module can be used inside a VC15 binary. Because this compatibility the version number of the Redistributable is 14.1x.xx and after you install the Redistributable VC2017, VC2015 is removed but you can still use VC14.

If you have a 64-bit Windows, you must install both 32 and 64bit versions of each VisualC++ package, even if you do not use Wampserver 64 bit
To verify that all VC ++ packages are installed and with the latest versions, you can use the tool:
http://wampserver.aviatechno.net/files/tools/check_vcredist.exe and you will find all the packages on http://wampserver.aviatechno.net/ in section Visual C++ Redistribuable Packages
You must install each package "as an administrator", so right-click the exe file and then run as Administrator. Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

Warning: Sometimes Microsoft may update the VC ++ package by breaking the download links and without redirect to the new. If the case happens to you, remember that item number 20 below will be updated and the page http://wampserver.aviatechno.net/ section Visual C++ Redistribuable Packages is up to date.
This is item number 20 of TROUBLESHOOTING TIPS of Wampserver:
 http://forum.wampserver.com/read.php?2,134915

Passo5: pasta ou diretório de instalação.

Clique em Next

Passo6: Menu.

Clique em Next

Passo7: Início da instalação.

Clique em Install

Passo8: processo de instalação.


Passo9: escolha o navegador.


Clique em sim

Passo10: escolha o navegador padrão.

Clique em Abrir

Passo11: esolha o editor de texto.

Clique em Sim.

Não aparecendo nehuma mensagem de erro a instalação foi correta.
O ícone do WampSever aparece no canto inferior direito da janela do Windows 10, ele deve ficar verde ao ser acessado.